Archive

Archive for March, 2009

Solution: Mythtv somtimes doesn’t detect the tuner cards

March 9, 2009 1 comment

As described here I fought the problem for a long time, that mythtv sometimes just refuses to detect the TV cards, when two TV cards are installed.

I think I found the solution to the problem now finally – the problem appears when the loading order of the driver modules are mixed up, so that Card1, which normally is linked to /dev/video0 is linked to /dev/video1 and vice versa for Card2 – that seems to confuse mythtv.

So, the trick is to define in mythbuntu (or Ubuntu+mythtv), that it should load Card1 before Card2 so that the corresponding linking to the video-devs is done correctly.

As Ubuntu uses udev, which is not really easy, I just did the old dirty trick:
1) blacklist both TV card modules (in my case: ivtv and bttv):

sudo vi /etc/modprobe.d/blacklist

and add :

blacklist ivtv
blacklist bttv

2) Load the modules in your desired order:

sudo vi /etc/modules

and add:

ivtv
bttv

That’s it – I hope it finally really works and will test it in the next days.

UPDATED2: Quick tip: Asus A8V-VM SE and mythtv

March 2, 2009 1 comment

I am running Mythbuntu 8.10 on my Asus A8V-VM SE with a Athlon 64 3200+ and faced severe problems. The most annoying one was the problem, that mythtv periodically wasn’t able to detect the tuner cards, although they were detected by the kernel and were configured correctly.

I tried several tips like moving the daemon call of mythtv-backend in /etc/rc5.d to a later position, from S25mythtv-backend to S99mythtv-backend – this didn’t really help. Until I finally got a setup, which works now in most cases or let’s say, nearly with all bootups.

So to help you preventing one or another headache, this is my setup wich works now really well:

In the Asus BIOS, you have to disable:
APIC
ACPI 2.0 support

and in Ubuntu, you have to add

noapic

in /boot/grub/menu.lst, so that it looks like this:


kernel /boot/vmlinuz-2.6.27-11-generic root=UUID=xyz ro locale=de_DE quiet noapic

The next article I am planning will describe how to setup mythwelcome and acpi wakeup with Mythbuntu 8.10 on the crappy Asus A8V-VM SE – stay tuned.

Update:
I recently posted exactly here another socalled dirty tip, which should solve the problem – but as I have faced the same problem today again, that mythtv sometimes just refuses to detect the cards, I deleted it. But I think (and hope) I found the real deal today, the problem, why mythtv sometimes just doesn’t detect the cards, although the kernel detects it correctly.

The solution is posted in another post here:
Link

Categories: Howto, Mythtv, Ubuntu Tags: , , , ,

Howto: Use Floppy in Ubuntu

March 1, 2009 9 comments

By default, the use of floppy drives is disabled in Ubuntu 8.10.
The reason for a not responding floppy under /dev/fd0 (standard device) is the deactivated kernel module for floppies. To permanently activate the module loading of the floppy, simply run in xterm:

gksudo gedit /etc/modules

and add this simple line to /etc/modules at the end of the file


floppy

Don´t forget to save (and overwrite) the file afterwards !!!

The Floppy will be now available after reboot – to use it instantly, simply type into xterm:


sudo modprobe floppy

To mount the floppy, add a mountpoint in /media like

sudo mkdir /media/floppy

and mount it with:

sudo mount /dev/fd0 /media/floppy

To permanently have the device linked to the mountpoint, edit /etc/fstab:

gksudo gedit /etc/fstab

and add this line:

/dev/fd0 /media/floppy auto rw,user,noauto,exec,utf8 0 0

Again, don´t forget to save (and overwrite) the file!!!

Categories: Uncategorized